jasmine-expect cannot find jest, jasmine v2.x, or jasmine v1.x

lomse

I'm trying unit test with jasmine-expect. However I keep getting the error:

jasmine-expect cannot find jest, jasmine v2.x, or jasmine v1.x

I have installed the latest version of jasmine. What am I missing?

package.json

{
  "name": "js",
  "version": "1.0.0",
  "description": "",
  "main": "Person.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "author": "",
  "license": "ISC",
  "devDependencies": {
    "add-matchers": "^0.4.0",
    "babel-cli": "^6.22.2",
    "babel-core": "^6.22.1",
    "babel-loader": "^6.2.10",
    "babel-preset-es2015": "^6.22.0",
    "babel-preset-react": "^6.22.0",
    "jasmine": "^2.5.3",
    "jasmine-expect": "^3.6.0",
    "jest": "^18.1.0",
    "webpack": "^2.2.1"
  },
  "dependencies": {
    "deep-freeze": "0.0.1"
  }
}

My Code:

'use strict';
import expect from 'jasmine-expect';

console.log('It is working...');

Error Message: enter image description here

lomse

I have switched to the mjackson expect library. It seems to be working fine. Thanks.

Collected from the Internet

Please contact [email protected] to delete if infringement.

edited at
0

Comments

0 comments
Login to comment

Related