在openshift中导入python模块

哈里克什

我的烧瓶应用程序正在运行openshift,我正在尝试requests在程序中导入模块。我已经加入依赖关系requirements.txt作为陈述这里

我的requirements.txt包含以下条目。

Flask==0.10.1
Requests=2.6.0

我得到500:内部服务器错误,当rhc tail我得到

ImportError:没有名为请求的模块

我想念什么吗?

更新:requirements.txt中有错误,它是==而不是=。

正确版本的requirements.txt应该看起来像这样。

Flask==0.10.1
Requests==2.6.0

但是我仍然面临问题,因为在git push我的日志状态中。

远程:找不到满足要求Requests == 2.6.0的版本(来自-r /var/lib/openshift/xxxxxxxxxxxxxxxxxx/app-root/runtime/repo/requirements.txt(第2行))(来自以下版本: 0.10.0、0.10.1、0.10.2、0.10.3、0.10.4、0.10.6、0.10.7、0.10.8、0.11.1、0.11.2、0.12.0、0.12.1、0.13。 0、0.13.1、0.13.2、0.13.3、0.13.4、0.13.5、0.13.6、0.13.7、0.13.8、0.13.9、0.14.0、0.14.1、0.14.2, 0.2.0、0.2.1、0.2.2、0.2.3、0.2.4、0.3.0、0.3.1、0.3.2、0.3.3、0.3.4、0.4.0、0.4.1、0.5。 0、0.5.1、0.6.0、0.6.1、0.6.2、0.6.3、0.6.4、0.6.5、0.6.6、0.7.0、0.7.1、0.7.2、0.7.3, 0.7.4、0.7.5、0.7.6、0.8.0、0.8.1、0.8.2、0.8.3、0.8.4、0.8.5、0.8.6、0.8.7、0.8.8、0.8。 9,0.9.0,0.9.1,0.9.2,0.9.3,1.0.0,1.0.1,1.0.2,1.0.3,1.0.4,1.1.0,1.2.0,1.2.1, 1.2.2、1.2.3、2.0.0、2.0.1、2.1.0、2.2.0、2.2.1、2.3.0、2.4.0、2.4.1、2.4.2、2.4.3、2.5。 0,2.5.1)远程:打扫干净...

替代解决方案:您可以SSH应用程序,并且可以按照此线程的回答使用pip手动安装软件包

娱乐

您应该放两个相等的符号:

Flask==0.10.1
Requests==2.5.1

或者

Requests>=2.5.1

或者,如@Paco建议的那样,

Requests 

注意:添加没有发行号的软件包通常是个坏主意。如果发布了较新的版本,并且该版本破坏了兼容性,则下次运行(直接运行或在构建项目时)可能会破坏所有功能。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章