已经需要Thor。这可能会导致Bundler发生意外故障

奇他唑

我正在开发Spree Gem,每次运行rake命令时,都会收到此消息

([email protected])[email protected]:~/avalancha/spree_mp$ bundle exec rake test_app --trace
Thor has already been required. This may cause Bundler to malfunction in unexpected ways.
** Invoke test_app (first_time)
** Execute test_app
** Invoke common:test_app (first_time)
** Execute common:test_app
Generating dummy Rails application...
Setting up dummy database...
Running extension installation generator...
      append  app/assets/javascripts/store/all.js
      append  app/assets/javascripts/admin/all.js
      insert  app/assets/stylesheets/store/all.css
      insert  app/assets/stylesheets/admin/all.css
         run  bundle exec rake railties:install:migrations FROM=spree_mercado_pago_payment_method from "."
Would you like to run the migrations now? [Y/n] Y
         run  bundle exec rake db:migrate from "."

为什么会发生这种情况,我该如何避免呢?

这是我的宝石文件

source 'http://rubygems.org'

gem 'spree', '~> 2.1.0'
gem 'spree_auth_devise', :git => 'https://github.com/spree/spree_auth_devise.git', :branch => '2-1-stable'

gemspec

和bundle env的输出:

([email protected])[email protected]:~/avalancha/spree_mp$ bundle env
Bundler 1.3.5
Ruby 2.0.0 (2013-06-27 patchlevel 247) [x86_64-linux]
Rubygems 2.1.10
rvm 1.23.13 (stable)
GEM_HOME /home/jperez/.rvm/gems/[email protected]
GEM_PATH /home/jperez/.rvm/gems/[email protected]:/home/jperez/.rvm/gems/[email protected]
rubygems-bundler (1.4.2)

Bundler settings
  local.spree_mercado_pago_payment_method
    Set for the current user (/home/jperez/.bundle/config): "/home/jperez/avalancha/spree_mp"


Gemfile
source 'http://rubygems.org'

gem 'spree', '~> 2.1.0'
gem 'spree_auth_devise', :git => 'https://github.com/spree/spree_auth_devise.git', :branch => '2-1-stable'


group :test do
  gem 'spork'
  gem 'guard-rspec'
  gem 'guard-spork'
  gem 'capybara'
end

gemspec


Gemfile.lock
GIT
  remote: https://github.com/spree/spree_auth_devise.git
  revision: 42204323be9e3eb4bd67c07d02dd77de6a6ac0d8
  branch: 2-1-stable
  specs:
    spree_auth_devise (2.1.0)
      cancan (~> 1.6.7)
      devise (~> 3.0.1)
      devise-encryptable (= 0.1.2)
      spree_backend (~> 2.1.0)
      spree_core (~> 2.1.0)
      spree_frontend (~> 2.1.0)

PATH
  remote: .
  specs:
    spree_mercado_pago_payment_method (0.1.1)
      rest-client
      spree_core (~> 2.1.0)

GEM
  remote: http://rubygems.org/
  specs:
    actionmailer (4.0.1)
      actionpack (= 4.0.1)
      mail (~> 2.5.4)
    actionpack (4.0.1)
      activesupport (= 4.0.1)
      builder (~> 3.1.0)
      erubis (~> 2.7.0)
      rack (~> 1.5.2)
      rack-test (~> 0.6.2)
    active_utils (2.0.1)
      activesupport (>= 2.3.11)
      i18n
    activemerchant (1.42.2)
      active_utils (~> 2.0, >= 2.0.1)
      activesupport (>= 2.3.14, < 5.0.0)
      builder (>= 2.1.2, < 4.0.0)
      i18n (~> 0.5)
      json (~> 1.7)
      money (< 7.0.0)
      nokogiri (~> 1.4)
    activemodel (4.0.1)
      activesupport (= 4.0.1)
      builder (~> 3.1.0)
    activerecord (4.0.1)
      activemodel (= 4.0.1)
      activerecord-deprecated_finders (~> 1.0.2)
      activesupport (= 4.0.1)
      arel (~> 4.0.0)
    activerecord-deprecated_finders (1.0.3)
    activesupport (4.0.1)
      i18n (~> 0.6, >= 0.6.4)
      minitest (~> 4.2)
      multi_json (~> 1.3)
      thread_safe (~> 0.1)
      tzinfo (~> 0.3.37)
    acts_as_list (0.2.0)
      activerecord (>= 3.0)
    arel (4.0.1)
    atomic (1.1.14)
    awesome_nested_set (3.0.0.rc.2)
      activerecord (~> 4.0.0)
    aws-sdk (1.27.0)
      json (~> 1.4)
      nokogiri (>= 1.4.4)
      uuidtools (~> 2.1)
    bcrypt-ruby (3.1.2)
    builder (3.1.4)
    cancan (1.6.10)
    canonical-rails (0.0.3)
      rails (>= 3.1, < 5.0)
    capybara (1.1.2)
      mime-types (>= 1.16)
      nokogiri (>= 1.3.3)
      rack (>= 1.0.0)
      rack-test (>= 0.5.4)
      selenium-webdriver (~> 2.0)
      xpath (~> 0.1.4)
    celluloid (0.15.2)
      timers (~> 1.1.0)
    childprocess (0.3.9)
      ffi (~> 1.0, >= 1.0.11)
    climate_control (0.0.3)
      activesupport (>= 3.0)
    cocaine (0.5.3)
      climate_control (>= 0.0.3, < 1.0)
    coderay (1.1.0)
    colorize (0.6.0)
    deface (1.0.0)
      colorize (>= 0.5.8)
      nokogiri (~> 1.6.0)
      rails (>= 3.1)
    devise (3.0.4)
      bcrypt-ruby (~> 3.0)
      orm_adapter (~> 0.1)
      railties (>= 3.2.6, < 5)
      warden (~> 1.2.3)
    devise-encryptable (0.1.2)
      devise (>= 2.1.0)
    diff-lcs (1.1.3)
    erubis (2.7.0)
    factory_girl (4.3.0)
      activesupport (>= 3.0.0)
    ffaker (1.21.0)
    ffi (1.9.3)
    formatador (0.2.4)
    guard (2.2.4)
      formatador (>= 0.2.4)
      listen (~> 2.1)
      lumberjack (~> 1.0)
      pry (>= 0.9.12)
      thor (>= 0.18.1)
    guard-rspec (2.5.4)
      guard (>= 1.1)
      rspec (~> 2.11)
    guard-spork (1.5.1)
      childprocess (>= 0.2.3)
      guard (>= 1.1)
      spork (>= 0.8.4)
    highline (1.6.20)
    hike (1.2.3)
    httparty (0.12.0)
      json (~> 1.8)
      multi_xml (>= 0.5.2)
    i18n (0.6.5)
    jquery-rails (3.0.4)
      railties (>= 3.0, < 5.0)
      thor (>= 0.14, < 2.0)
    jquery-ui-rails (4.0.5)
      railties (>= 3.1.0)
    json (1.8.1)
    kaminari (0.14.1)
      actionpack (>= 3.0.0)
      activesupport (>= 3.0.0)
    listen (2.2.0)
      celluloid (>= 0.15.2)
      rb-fsevent (>= 0.9.3)
      rb-inotify (>= 0.9)
    lumberjack (1.0.4)
    mail (2.5.4)
      mime-types (~> 1.16)
      treetop (~> 1.4.8)
    method_source (0.8.2)
    mime-types (1.25)
    mini_portile (0.5.2)
    minitest (4.7.5)
    money (5.1.1)
      i18n (~> 0.6.0)
    multi_json (1.8.2)
    multi_xml (0.5.5)
    nokogiri (1.6.0)
      mini_portile (~> 0.5.0)
    orm_adapter (0.5.0)
    paperclip (3.4.2)
      activemodel (>= 3.0.0)
      activerecord (>= 3.0.0)
      activesupport (>= 3.0.0)
      cocaine (~> 0.5.0)
      mime-types
    paranoia (2.0.1)
      activerecord (~> 4.0)
    polyamorous (0.6.4)
      activerecord (>= 3.0)
    polyglot (0.3.3)
    pry (0.9.12.4)
      coderay (~> 1.0)
      method_source (~> 0.8)
      slop (~> 3.4)
    rabl (0.8.4)
      activesupport (>= 2.3.14)
    rack (1.5.2)
    rack-test (0.6.2)
      rack (>= 1.0)
    rails (4.0.1)
      actionmailer (= 4.0.1)
      actionpack (= 4.0.1)
      activerecord (= 4.0.1)
      activesupport (= 4.0.1)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.0.1)
      sprockets-rails (~> 2.0.0)
    railties (4.0.1)
      actionpack (= 4.0.1)
      activesupport (= 4.0.1)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (10.1.0)
    ransack (1.1.0)
      actionpack (>= 3.0)
      activerecord (>= 3.0)
      polyamorous (~> 0.6.0)
    rb-fsevent (0.9.3)
    rb-inotify (0.9.2)
      ffi (>= 0.5.0)
    rest-client (1.6.7)
      mime-types (>= 1.16)
    rspec (2.11.0)
      rspec-core (~> 2.11.0)
      rspec-expectations (~> 2.11.0)
      rspec-mocks (~> 2.11.0)
    rspec-core (2.11.1)
    rspec-expectations (2.11.3)
      diff-lcs (~> 1.1.3)
    rspec-mocks (2.11.3)
    rspec-rails (2.11.4)
      actionpack (>= 3.0)
      activesupport (>= 3.0)
      railties (>= 3.0)
      rspec (~> 2.11.0)
    rubyzip (1.0.0)
    sass (3.2.12)
    sass-rails (4.0.1)
      railties (>= 4.0.0, < 5.0)
      sass (>= 3.1.10)
      sprockets-rails (~> 2.0.0)
    select2-rails (3.4.9)
      sass-rails
      thor (~> 0.14)
    selenium-webdriver (2.37.0)
      childprocess (>= 0.2.5)
      multi_json (~> 1.0)
      rubyzip (~> 1.0.0)
      websocket (~> 1.0.4)
    slop (3.4.7)
    spork (0.9.2)
    spree (2.1.3)
      spree_api (= 2.1.3)
      spree_backend (= 2.1.3)
      spree_cmd (= 2.1.3)
      spree_core (= 2.1.3)
      spree_frontend (= 2.1.3)
      spree_sample (= 2.1.3)
    spree_api (2.1.3)
      rabl (= 0.8.4)
      spree_core (= 2.1.3)
      versioncake (~> 1.2.0)
    spree_backend (2.1.3)
      jquery-rails (~> 3.0.0)
      jquery-ui-rails (~> 4.0.0)
      select2-rails (~> 3.4.7)
      spree_api (= 2.1.3)
      spree_core (= 2.1.3)
    spree_cmd (2.1.3)
      thor (~> 0.14)
    spree_core (2.1.3)
      activemerchant (= 1.42.2)
      acts_as_list (= 0.2.0)
      awesome_nested_set (~> 3.0.0.rc.2)
      aws-sdk (= 1.27.0)
      cancan (~> 1.6.10)
      deface (~> 1.0.0)
      ffaker (~> 1.16)
      highline (~> 1.6.18)
      httparty (~> 0.11)
      json (~> 1.7)
      kaminari (~> 0.14.1)
      money (~> 5.1)
      paperclip (~> 3.4.1)
      paranoia (~> 2.0)
      rails (~> 4.0.0)
      ransack (= 1.1.0)
      state_machine (= 1.2.0)
      stringex (~> 1.5.1)
      truncate_html (= 0.9.2)
    spree_frontend (2.1.3)
      canonical-rails
      jquery-rails (~> 3.0.0)
      spree_api (= 2.1.3)
      spree_core (= 2.1.3)
      stringex (~> 1.5.1)
    spree_sample (2.1.3)
      spree_core (= 2.1.3)
    sprockets (2.10.0)
      hike (~> 1.2)
      multi_json (~> 1.0)
      rack (~> 1.0)
      tilt (~> 1.1, != 1.3.0)
    sprockets-rails (2.0.1)
      actionpack (>= 3.0)
      activesupport (>= 3.0)
      sprockets (~> 2.8)
    sqlite3 (1.3.8)
    state_machine (1.2.0)
    stringex (1.5.1)
    thor (0.18.1)
    thread_safe (0.1.3)
      atomic
    tilt (1.4.1)
    timers (1.1.0)
    treetop (1.4.15)
      polyglot
      polyglot (>= 0.3.1)
    truncate_html (0.9.2)
    tzinfo (0.3.38)
    uuidtools (2.1.4)
    versioncake (1.2.0)
      actionpack (>= 3.2)
      activesupport (>= 3.2)
      railties (>= 3.2)
      tzinfo
    warden (1.2.3)
      rack (>= 1.0)
    websocket (1.0.7)
    xpath (0.1.4)
      nokogiri (~> 1.3)

PLATFORMS
  ruby

DEPENDENCIES
  capybara
  factory_girl
  ffaker
  guard-rspec
  guard-spork
  rspec-rails (~> 2.11.0)
  sass-rails
  spork
  spree (~> 2.1.0)
  spree_auth_devise!
  spree_mercado_pago_payment_method!
  sqlite3
奇他唑

根据Spree开发人员的说法:

您看到的只是一个警告。您可以放心地忽略它。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

NetTcpBinding(WCF)中的ReliableSession发生意外故障

VM正在使用latin1的本机名称编码运行,这可能会导致Elixir如预期的那样发生故障

useState()导致音频对象发生意外行为

JavaScript可能发生意外迭代

修复“您已在此页面上多次包含Google Maps API。这可能会导致意外错误。”

在lint分析module-info.class期间发生意外故障

TCP插件发生意外错误

BaseDexClassLoader中发生意外崩溃

结帐后发生意外变化

与Stripe发生意外错误

)此时发生意外错误

Numpy阵列发生意外变化

登录错误:发生意外错误

等待调用导致实例属性发生意外行为

Android Studio 2.3更新:警告:使用不兼容的插件进行注释处理:android-apt。这可能会导致意外行为

XQuery发生错误时发生意外

Nodemon这可能会导致较高的cpu使用率。减少使用--watch

[Vue警告]:检测到重复的密钥:x。这可能会导致更新错误

无法修复警告检测到重复键:“ 0”。这可能会导致更新错误

通过.whereArrayContains()查询时发生意外行为

在Blazor中使用JsonPatchDocument发生意外错误

angular js中发生意外错误

在python中读取文件时发生意外中断

vue.js发生意外的选择下拉行为

为什么我的对象发生意外变化?

Go的。(type)取消编组JSON时发生意外

拆分代码行时发生意外的令牌ILLEGAL错误

使用Jest发生意外的保留字错误

定制jcombobox标题中的背景发生意外变化