Mac OS X上的Python

有人

我认为我在OS X 10.8上安装python时遇到了一些问题。这是我得到which命令后得到的

$ which -a python
/usr/local/bin/python
/usr/bin/python
/usr/local/bin/python

那我有

$ /usr/local/bin/python --version
Python 2.7.5

尽管

/usr/bin/python --version
Python 2.5.6

我已经安装了自制软件。问题是程序(Tex Live Utility)崩溃,因为它需要Python 2.6+并/usr/bin/python用作路径。我的问题是,OS X随附的是哪个python版本?如何解决此问题而不弄乱Apple的Python安装?

顺便说一句,在/ usr / bin文件夹中,我有以下内容

$ ls py*
pydoc           python2.5       pythonw
pydoc2.5        python2.5-config    pythonw2.5
pydoc2.6        python2.6       pythonw2.6
pydoc2.7        python2.6-config    pythonw2.7
python          python2.7
python-config       python2.7-config
埃里克·卡普伦
  • /usr/bin/python 是OS X随附的Python。
  • /usr/local/bin/python 是Homebrew版本。

这也解释了为什么第二个是较新的。另外,如果您安装了Homebrew,则Homebrew已/usr/local正常安装了下面的所有文件

PS:为什么您的OS X Python版本为2.6.5,我对此有些怀疑。在OS X 10.8中,捆绑的Python应该是2.7.2,就像我的系统一样:

$ /usr/bin/python --version
Python 2.7.2

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

TOP 榜单

热门标签

归档