错误:无法解析:com.google.firebase:火力碰撞:17.2.2

新:

我试图更新我的谷歌和火力SDK库在我的项目要解决的问题INSTALL_REFERRER弃用,但我同步后得到的错误

ERROR: Failed to resolve: com.google.firebase:firebase-crash:17.2.2

并在此错误合并清单

ERROR: Manifest merger failed : Attribute [email protected] value=(android.support.v4.app.CoreComponentFactory) from [com.android.support:support-compat:28.0.0] AndroidManifest.xml:22:18-91
    is also present at [androidx.core:core:1.0.0] AndroidManifest.xml:22:18-86 value=(androidx.core.app.CoreComponentFactory).
    Suggestion: add 'tools:replace="android:appComponentFactory"' to <application> element at AndroidManifest.xml:28:5-422:19 to override.

这里是我的火力和谷歌的依赖

    implementation 'com.google.firebase:firebase-analytics:17.2.2'
    implementation 'com.google.firebase:firebase-crash:17.2.2'
    implementation 'com.google.firebase:firebase-config:19.1.1'
    implementation 'com.google.firebase:firebase-auth:19.2.0'
    implementation 'com.google.android.gms:play-services-auth:17.0.0'

    implementation 'com.google.android.gms:play-services-base:17.1.0'
    implementation 'com.google.android.gms:play-services-analytics:16.0.8'
    implementation 'com.google.android.gms:play-services-maps:17.0.0'

    implementation 'com.google.firebase:firebase-core:17.2.2'
    implementation 'com.google.firebase:firebase-ads:18.3.0'
    implementation 'com.google.firebase:firebase-messaging:20.1.0'
彼得·哈达德:

使用以下依赖性:

implementation 'com.google.firebase:firebase-crashlytics:17.0.0-beta01'

和更新您的应用程序使用AndroidX:

升级com.android.tools.build:gradle到V3.2.1或更高版本。

升级compileSdkVersion到28或更高版本。

更新您的应用程序使用的Jetpack(AndroidX); 按照迁移到AndroidX的说明。

https://developer.android.com/jetpack/androidx/migrate

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

TOP 榜单

热门标签

归档