ModuleNotFoundError:没有名为“ buildozer”的模块

Reihaneh Kouhi:

我正在尝试使用此处的步骤在Linux上安装buildozer:https://kivy.org/doc/stable/guide/packaging-android.html

当我使用命令行时:buildozer init

我收到此错误:

File "/home/kouhi/.local/bin/buildozer", line 5, in <module>
from buildozer.scripts.client import main
ModuleNotFoundError: No module named 'buildozer'

有解决这个问题的想法吗?先感谢您

PS:一切都从将我的python从3.5更新到3.7开始!!!在那之前一切都很好

p0rc0_r0ss0:

只是一个观察,但是某些在python 3.6上运行的应用程序在3.7+上失败了。最不幸的是,这些应用程序之一是我的,并且对于某些不兼容性没有可靠的解决方案。我的意思是我必须将python降级到3.6版本。希望能帮助到你。

但是,其他方法是通过pip安装:

pip search buildozer

buildozer (1.0)      - Generic Python packager for Android / iOS and Desktop
buildertron (0.1.0)  - A buildozer front-end for Linux

而且当然

python -m pip install buildozer 

无法保证它会起作用,但是至少在依赖项方面您会很安全。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

ModuleNotFoundError:没有名为“ knox”的模块

ModuleNotFoundError:没有名为“项目”的模块

ModuleNotFoundError:没有名为“ camelcase”的模块

ModuleNotFoundError: 没有名为“model”的模块

ModuleNotFoundError: 没有名为“src”的模块

ModuleNotFoundError:没有名为“ fastai”的模块

ModuleNotFoundError:没有名为“dmidecode”的模块

ModuleNotFoundError: 没有名为“tensorboard”的模块

ModuleNotFoundError:没有名为“ pynput”的模块

ModuleNotFoundError:没有名为“ jieba”的模块

ModuleNotFoundError:没有名为“ matplotlib”的模块

ModuleNotFoundError:没有名为“模型”的模块

ModuleNotFoundError: 没有名为“bootstrapform”的模块

ModuleNotFoundError:没有名为“ BaseHTTPServer”的模块

ModuleNotFoundError:没有名为“ Cython”的模块

ModuleNotFoundError:没有名为“ gin”的模块

ModuleNotFoundError:没有名为“ mglearn”的模块

ModuleNotFoundError:没有名为“烧瓶”的模块

ModuleNotFoundError:没有名为“python”的模块

ModuleNotFoundError:没有名为“建模”的模块

ModuleNotFoundError: 没有名为“aiohttp”的模块

ModuleNotFoundError:没有名为“ printSoln”的模块

ModuleNotFoundError:没有名为“ lxml”的模块

ModuleNotFoundError:没有名为“ ruamel”的模块

ModuleNotFoundError:没有名为“ jose”的模块

ModuleNotFoundError:没有名为“ Ipython”的模块

ModuleNotFoundError:没有名为“表单”的模块

ModuleNotFoundError:没有名为“ Scrapy”的模块

ModuleNotFoundError:没有名为“ selenium”的模块