如何从github导入包

PoojaDinakaran:

我正在尝试使用Go构建api,并且尝试运行从udemy课程获得的来自GitHub的现有文件。我得到这种输出:

C:\goworkspace\src\grpc-go-course-master\blog\blog_client>go run client.go
client.go:4:2: cannot find package "context" in any of:
        C:\go\src\context (from $GOROOT)
        C:\goworkspace\src\context (from $GOPATH)
..\..\..\golang.org\x\net\http2\not_go111.go:10:2: cannot find package "net/http/httptrace" in any of:
        C:\go\src\net\http\httptrace (from $GOROOT)
        C:\goworkspace\src\net\http\httptrace (from $GOPATH)

您能建议我什么原因导致此错误吗?

alessiosavi:

为了下载依赖项,您必须使用以下go get命令:

go get -v -u github.com/alessiosavi/GoUtils

更改所需的软件包(在该存储库中,您可以找到许多“ utils”方法)。

如果该项目有go.mod文件,则必须键入:

go clean
go build

这样,您将安装go.mode文件中列出的依赖项

要将依赖关系更新到最新版本:

go get -v -u all

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

TOP 榜单

热门标签

归档