没有名为'tensorflow.keras.layers.experimental.preprocessing'的模块

Imdadul haque

下面的代码

import numpy as np
np.random.seed(0)
from sklearn import datasets
import matplotlib.pyplot as plt
%matplotlib inline
%config InlineBackend.figure_format ='retina'

from keras.models import Sequential
from keras.layers import Dense
from keras.optimizers import SGD

错误消息下方

---------------------------------------------------------------------------
ModuleNotFoundError                       Traceback (most recent call last)
~\Anaconda3\lib\site-packages\keras\__init__.py in <module>
      2 try:
----> 3     from tensorflow.keras.layers.experimental.preprocessing import RandomRotation
      4 except ImportError:

ModuleNotFoundError: No module named 'tensorflow.keras.layers.experimental.preprocessing'

During handling of the above exception, another exception occurred:

ImportError                               Traceback (most recent call last)
<ipython-input-5-943507dd87a6> in <module>
      6 get_ipython().run_line_magic('config', "InlineBackend.figure_format ='retina'")
      7 
----> 8 from keras.models import Sequential
      9 from keras.layers import Dense
     10 from keras.optimizers import SGD

~\Anaconda3\lib\site-packages\keras\__init__.py in <module>
      4 except ImportError:
      5     raise ImportError(
----> 6         'Keras requires TensorFlow 2.2 or higher. '
      7         'Install TensorFlow via `pip install tensorflow`')
      8 

ImportError: Keras requires TensorFlow 2.2 or higher. Install TensorFlow via `pip install tensorflow

注意:`我认为,主要问题是Tensorflow版本。我用了somes命令,那是在下面,

conda create -n tf tensorflow
conda activate tf

而且我还使用了以下命令

conda create -n tf-gpu tensorflow-gpu
conda activate tf-gpu

但它不起作用,请帮助解决错误。

灰烬16

您需要更新TensorFlow。您可以尝试

pip install tensorflow==2.0.0

或者,如果您使用的是gpu版本

pip install tensorflow-gpu==2.0.0 

有关更多详细信息,请在本期中关注此答案

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章