在conda环境中在Raspberry Pi 4上安装熊猫时出错

闪闪发光

我正在尝试使用将熊猫安装到我的conda环境中,conda install pandas但是安装失败,因为熊猫具有pytz和pytz的依赖关系requires a minimum conda version of 4.3.

如果我在普通的Linux机器上运行它,我将使用'conda update conda'更新conda,所有内容都会被排序...但是... Rasperry Pi上conda的最新受支持版本是4.2.13(使用rpi conda频道conda config --add channels rpi)。

救命!真的不可能在Raspberry Pi 4B的conda环境中使用熊猫吗?

复制问题:

Raspberry Pi 4B,带有64GB SD卡的8GB RAM)
OS:Raspbian Buster(10)(lsb_release -irdc
IDE:Spyder 4
Python:3.4.3(python --version
虚拟环境:Conda(Miniconda发行
Conda版本:4.2.13(linux-armv7l) (conda info

当前的conda环境(conda list):

conda         4.2.13
conda-env     2.6.0
ncurses       6.1
openssl       1.0.1k
pip           20.1.1
psycosat      0.6.1
pycrpto       2.6.1
python        3.4.3
pyyaml        3.11
readline      7.0
requests      2.7.0
ruamel_yaml   0.11.14
setuptools    18.1
SQLite        3.24.0
wheel         0.34.2
xz            5.0.5
yaml          0.1.7
zlib          1.1.11

相关问题:
对类似问题的过时答案(不再支持Berry Conda / RPI通道):Raspberry Pi-Python:在Python 3.5.2上安装Pandas

安装旧版本的熊猫并且不将其安装到虚拟环境中:https : //raspberrypi.stackexchange.com/questions/17073/how-do-i-install-pandas-on-raspberry-pi

西蒙

我遇到了完全相同的问题。解决方案是转储miniconda(python = 3.4)并使用virtualenv和pip(使用系统版本python 3.7)。然后一切顺利。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章