pip安装错误命令“ python setup.py egg_info”失败,错误代码为1

简哈维D

我正在尝试使用以下命令在Ubuntu终端上安装Monkeytype:

pip install monkeytype 

但我收到一个错误消息:

Command "python setup.py egg_info" failed with error code 1 

这是完整的日志:

bash-4.3$ pip install monkeytype
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting monkeytype
  Using cached https://files.pythonhosted.org/packages/5f/59/43bc6e44d69bd268e545fdfacdd6866362aca57ac894bbc3177b5455c06a/MonkeyType-18.2.0.tar.gz
Collecting retype (from monkeytype)
  Using cached https://files.pythonhosted.org/packages/6e/da/ca9f5560f051d2ed79a52de1170903e3ff8ad011cff56c65abfcff38d372/retype-17.12.0.tar.gz
    ERROR: Complete output from command python setup.py egg_info:
    ERROR: Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-mCIobj/retype/setup.py", line 14, in <module>
        assert sys.version_info >= (3, 6, 0), "retype requires Python 3.6+"
    AssertionError: retype requires Python 3.6+
    ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-mCIobj/retype/
马丁

使用pip install,真正的错误总是隐藏在日志的后面,因为pip运行软件包的安装例程。

在您的情况下,请检查ERROR: Traceback,指出“重新输入要求Python 3.6+”。

因此,已安装的程序包需要Python 3.6,但从先前的错误消息中,我们可以推断出您的pip运行python 2.7(查找DEPRECATION: Python 2.7

因此,通过使用pip3运行命令来修复错误python3 pip

要验证使用的是哪个python版本,请致电pip -V

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

Python 3.5 setup.py egg_info失败,错误代码为1 [Linux]

Python多处理安装:命令“ python setup.py egg_info”失败,错误代码为1

Python-命令“ python setup.py egg_info”在/ tmp / pip-build-21ft0H / pandas中失败,错误代码为1

无法安装pyzmail-“命令“ python setup.py egg_info”失败,错误代码为1”

使用pip安装pygame:命令“ python setup.py egg_info”失败,错误代码为1

无法安装Django:/ tmp / pip-build-rcF9a5 / Django /中的命令“ python setup.py egg_info”失败,错误代码为1

安装“模式”时,命令“ python setup.py egg_info”失败,错误代码为1

提示安装“ python setup.py egg_info”的Pip安装失败,错误代码为1错误

pip install psycopg2 == 2.6给出错误命令“ python setup.py egg_info”失败,错误代码为/ tmp / pip-build-f6rRmm / psycopg2 /

无法为Python 3.7的pip安装pygame-命令“ python setup.py egg_info”失败,错误代码为1

AWS EB CLI安装失败,显示“ python setup.py egg_info”失败,错误代码为“ 1”

“ pip安装模型”-“ python setup.py egg_info”失败,错误代码为1

表包中的命令“ python setup.py egg_info”失败,错误代码为1

python pip install poster给我错误->命令“ python setup.py egg_info”在C:\ Users \中失败,错误代码为1

命令“ python setup.py egg_info”失败,错误代码为1 **升级setuptools不起作用!**

错误:/ tmp / pip-install-YYFUnW / psycopg2 /中的命令“ python setup.py egg_info”失败,错误代码为1

命令“ python setup.py egg_info”在/ tmp / pip-build-rnhk49o3 / opencv-python /中失败,错误代码为1

命令“ python setup.py egg_info”在/ tmp / pip-install-EC5FHz / tornado /中失败,错误代码为1

pip install pygame产生命令“ python setup.py egg_info”失败,错误代码为/ tmp / pip-build-vD9diA / pygame /

Python /安装cvxpy软件包错误-setup.py egg_info,错误代码为1

“ python setup.py egg_info失败,错误代码为1

python setup.py egg_info 失败,错误代码为 1

错误安装 Hachoir-metadata |命令“python setup.py egg_info”失败,错误代码 1 in...\hachoir-metda

Cloud Foundry 上的 Flask 应用程序 - 命令“python setup.py egg_info”失败,错误代码为 1

错误:“python setup.py egg_info”失败,错误代码为 1

如何修复错误“命令“python setup.py egg_info”在 C:\Users\Dell\AppData\Local\Temp\pip-install-r1jk6xfr\pandas\ 中出现错误代码 1 失败?

气流安装错误:"python setup.py egg_info" failed with error code 1"

Twyton / 命令“python setup.py egg_info”在 /tmp/pip-install-ui3eeW/twython/ 中失败,错误代码为 1

命令“python setup.py egg_info”在 /tmp/pip-build-dlih6aks/MarkupSafe/ 中失败,错误代码为 1