将 Python Twint 模块导入 Jupyter Notebook 时出现问题 - ModuleNotFoundError:没有名为“twint”的模块

吉米

当我尝试将twint包 ( https://pypi.org/project/twint/ )导入Jupyter Notebook 时,我收到一条错误消息。

import twint

ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-1-5772b804c290> in <module>
----> 1 import twint

ModuleNotFoundError: No module named 'twint' 

不过我知道twint安装好了。

C:\Users\my_user>pip show twint

Name: twint
Version: 2.1.20
Summary: An advanced Twitter scraping & OSINT tool.
Home-page: https://github.com/twintproject/twint
Author: Cody Zacharias
Author-email: [email protected]
License: MIT
Location: c:\users\my_user\appdata\local\programs\python\python39\lib\site-packages
Requires: beautifulsoup4, pysocks, aiohttp, cchardet, googletransx, schedule, geopy, fake- 
useragent, aiohttp-socks, elasticsearch, pandas, aiodns
Required-by:

我在尝试使用 twint (Python Module) 的 Atom 上查看了Python "ImportError: No module named twint",我知道我没有安装两个版本的 python。

我该如何前进?我想使用这个或类似的模块,而不是 Twitter API。

谢谢!

托马斯·拉特科夫斯基

今天早上我在尝试开始使用 twint 时遇到了同样的问题。似乎 twint 仅与 python 3.6 兼容,而我使用的是更新版本。我下载了 python 3.6,并在命令行中运行了“python3.6 -m pip install twint”。似乎现在工作。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章