在Mac OS X上将Python3与CMake链接

Yuheng Zou

我正在使用CMake。我想将Python3库链接到我的项目。我通过自制软件安装了Python3,并这样写CMakeLists.txt

find_package(PythonLibs 3.6 REQUIRED)

但这给了我一个错误:

Could NOT find PythonLibs: Found unsuitable version "2.7.10", but required
is at least "3.6" (found /usr/lib/libpython2.7.dylib)

此错误在Mac OS X上发生。有人可以告诉我如何解决它吗?谢谢。

Yuheng Zou

我已经解决了这个问题,所以我自己回答这个问题。

CMake无法找到Homebrew安装的Python。但是,您可以从源代码构建Python并进行安装,然后CMake可以找到它。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

TOP 榜单

热门标签

归档