Android Studio 2.3更新:警告:使用不兼容的插件进行注释处理:android-apt。这可能会导致意外行为

法律不纯

因此,我已经阅读了有关此问题的所有问题。我还与一位具有类似问题的开发人员(有能力解决此问题)进行了评论聊天。

我没有在gradle脚本中的任何位置写apt或commentProcessor。

我的代码中没有任何地方写有android-apt这个词。我什至继续检查所有的图书馆。这些都包含在我的项目中。

这是一个非常大的问题,需要解决。

我将在下面附加修改后的build.gradle,请提出以下建议:

    apply plugin: 'com.android.application'
apply plugin: 'realm-android'


android {
    dexOptions {
        jumboMode = true
    }

    compileSdkVersion rootProject.ext.compileSdkVersion
    buildToolsVersion rootProject.ext.buildToolsVersion


    useLibrary 'org.apache.http.legacy'
    defaultConfig {
        applicationId "com.legalimpurity.indiancourts"
        minSdkVersion rootProject.ext.minSdkVersion
        targetSdkVersion rootProject.ext.targetSdkVersion
        versionCode rootProject.ext.versionCode
        versionName rootProject.ext.versionName

        multiDexEnabled true
        vectorDrawables.useSupportLibrary = true;
    }
    buildTypes {
        release {
//            minifyEnabled true
//            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    signingConfigs {
    }

    dataBinding {
        enabled = true
    }



}
//For Facebook i guess
repositories {
    mavenCentral()
    maven {
        url "https://jitpack.io"
    }
    maven { url 'https://maven.fabric.io/public' }
}
def var = dependencies {
    annotationProcessor 'com.jakewharton:butterknife-compiler:8.5.1'

    compile 'com.google.android.gms:play-services-auth:9.4.0'
    compile 'com.google.android.gms:play-services-analytics:9.4.0'
    compile 'com.google.android.gms:play-services-plus:9.4.0'
    compile 'com.google.android.gms:play-services-ads:9.4.0'
    compile 'com.google.android.gms:play-services-identity:9.4.0'
//    compile 'com.google.android.gms:play-services-gcm:9.4.0'

    compile 'com.google.firebase:firebase-messaging:9.4.0'


    compile "com.android.support:appcompat-v7:${rootProject.ext.supportLibVersion}"
    compile "com.android.support:cardview-v7:${rootProject.ext.supportLibVersion}"
    compile "com.android.support:recyclerview-v7:${rootProject.ext.supportLibVersion}"
    compile "com.android.support:design:${rootProject.ext.supportLibVersion}"
    compile "com.android.support:support-v4:${rootProject.ext.supportLibVersion}"



    compile('com.github.ozodrukh:CircularReveal:[email protected]') {
        transitive = true;
    }
    compile 'com.amulyakhare:com.amulyakhare.textdrawable:1.0.1'
    compile 'com.android.support:multidex:1.0.1'

//    compile 'com.joanzapata.pdfview:android-pdfview:[email protected]'
    compile 'com.github.barteksc:android-pdf-viewer:2.4.0'
    compile 'com.wdullaer:materialdatetimepicker:3.1.3'


    compile 'com.facebook.android:account-kit-sdk:4.+'


    compile 'com.android.volley:volley:1.0.0'

//    compile 'com.facebook.android:facebook-android-sdk:4.6.0'


//    compile 'com.satsuware.lib:usefulviews:2.3.6'

    compile 'com.hkm:hkmprocessbuttons:1.2.4'
    compile 'com.github.thorbenprimke:realm-searchview:0.9.6'

    compile 'com.jakewharton:butterknife:8.5.1'
//    compile 'com.github.amlcurran.showcaseview:library:5.4.3'
    compile 'com.github.deano2390:MaterialShowcaseView:1.1.0'
//    compile 'com.zaihuishou:expandablerecycleradapter-databinding:1.0.0'
//    compile 'com.squareup.picasso:picasso:2.5.2'

//    compile 'com.legalimpurity.expandablerecyclerview:expandable-recyclerview:1.0'
    compile project(':agendacalendarview')
    compile project(':expandablelibrary')
    annotationProcessor 'com.jakewharton:butterknife-compiler:8.5.1'
    compile 'com.android.support:support-v4:25.+'

}
apply plugin: 'com.jakewharton.butterknife'
apply plugin: 'com.google.gms.google-services'

configurations.all {
    resolutionStrategy {
        force "com.android.support:support-annotations:25.2.0"
    }
}
僵尸

使用旧版本的Realm android-apt您应该升级realm-android插件版本。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章