Jupyter Notebook ModuleNotFoundError:没有名为“sklearn.impute”的模块

泰勒

我正在导入sklean.impute.SimpleImputer使用

from sklearn.impute import SimpleImputer

但是出错了

错误:没有名为“sklearn.impute”的模块。

使用命令安装 sklearn 0.19.1 !pip install sklearn怎么看是不是开发版?另外,我可以在哪里访问日志?

用户2653663

编辑:scikit-learn 的 pip 版本现在是 0.20+。

impute 子模块是 scikit-learn 0.20 版的一部分。它尚未在 pypi 上,因此如果您必须使用该功能,请通过以下方式安装 scikit-learn 的开发版本pip install git+https://github.com/scikit-learn/scikit-learn.git

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章