VM正在使用latin1的本机名称编码运行,这可能会导致Elixir如预期的那样发生故障

鲁斯塔姆·加萨诺夫(Rustam A.

如何解决每次我执行Elixir代码或输入时提示的警告iex

警告:VM正在以latin1的本机名称编码运行,这可能会导致Elixir如预期的utf8那样发生故障。请确保您的语言环境设置为UTF-8(可以通过在Shell中运行“ locale”进行验证)

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LANGUAGE=en_US:
LC_CTYPE=UTF-8
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04 LTS
Release:        14.04
Codename:       trusty
鲁斯塔姆·加萨诺夫(Rustam A.

问题显然没有LC_ALL=解决,我检查了一下

$ cat /etc/default/locale
LANG="en_US.utf8"
LANGUAGE="en_US:"

确保LC_ALL缺少,要修复它,我执行了:

$ sudo update-locale LC_ALL=en_US.UTF-8

此命令添加LC_ALL/etc/default/locale文件中:

$ cat /etc/default/locale
LANG="en_US.utf8"
LANGUAGE="en_US:"
LC_ALL=en_US.UTF-8

错误消失了。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

已经需要Thor。这可能会导致Bundler发生意外故障

Nodemon这可能会导致较高的cpu使用率。减少使用--watch

从异步方法中,是否正在调用LINQ查询的ToList,而不是ToListAsync,这可能会导致死锁?

[Vue警告]:检测到重复的密钥:x。这可能会导致更新错误

无法修复警告检测到重复键:“ 0”。这可能会导致更新错误

MySQL“设置名称latin1”似乎导致数据存储为utf8

变量 'loginusername' 在被赋值之前使用。运行时可能会导致空引用异常

Android Studio 2.3更新:警告:使用不兼容的插件进行注释处理:android-apt。这可能会导致意外行为

强制Postgres使用UTF8编码而不是LATIN1进行安装?

MySQL函数将使用Latin1编码的文本字段转换为UTF8

MYSQL数据库编码,混合使用latin1和utf-8

在 JPA 中使用 LATIN1 客户端编码执行 PostgreSQL 函数

避免使用$ rootScope。$ on-可能会导致内存泄漏

Android:使用getResources可能会导致我的应用崩溃

在调度之间检测到状态突变,在路径 `...` 中。这可能会导致不正确的行为

绝对值函数“ fabsf”的参数类型为“ double”,但参数类型为“ float”,这可能会导致值被截断?

修复“您已在此页面上多次包含Google Maps API。这可能会导致意外错误。”

vue.js检测到重复的密钥:“ topic.ID”。这可能会导致更新错误。怎么了

编码和解码UTF-8和latin1

与latin1和uft-8兼容的编码?

警告变量“csCryptoStream”在被赋值之前被使用。运行时可能会导致空引用异常

IDE的Java运行时(1.8u111)已过时-这可能会导致稳定性问题。在Ubuntu 16.10中打开PhpStorm时,请更新至1.8.0u112或更高版本

尝试合并两列以创建数据框名称时,可能会导致SyntaxError的原因?

检索正在运行的动画中轻按的UIButton,该动画可能会稍微偏离屏幕

除了存储空间不足之外,什么原因可能会导致[INSTALL_FAILED_INSUFFICIENT_STORAGE]故障?

从x到y的协变量数组转换可能会导致运行时异常

导入zbar会导致python以退出代码139退出-在运行10.9的Mac上,这可能导致什么呢?

不允许在取消分配时尝试加载视图控制器的视图,这可能会导致未定义的行为

Ag-grid:从getRowNodeId回调中检测到重复的节点ID 107,这可能会导致网格出现问题

TOP 榜单

热门标签

归档