无法装载动态库“libnvinfer.so.6”

同样贾汉吉:

我想正常导入TensorFlow Python包,但我得到了以下错误:

在这里输入图像描述

这里是从上述终端图像的文本:

2020-02-23 19:01:06.163940: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library 'libnvinfer.so.6'; dlerror: libnvinfer.so.6: cannot open shared object file: No such file or directory
2020-02-23 19:01:06.164019: W tensorflow/stream_executor/platform/default/dso_loader.cc:55] Could not load dynamic library 'libnvinfer_plugin.so.6'; dlerror: libnvinfer_plugin.so.6: cannot open shared object file: No such file or directory
2020-02-23 19:01:06.164030: W tensorflow/compiler/tf2tensorrt/utils/py_utils.cc:30] Cannot dlopen some TensorRT libraries. If you would like to use Nvidia GPU with TensorRT, please make sure the missing libraries mentioned above are installed properly.
<module 'tensorflow_core._api.v2.version' from '/home/saman/miniconda3/envs/testconda/lib/python3.7/site-packages/tensorflow_core/_api/v2/version/__init__.py'
的Jakub:

这是一个警告,而不是错误。您仍然可以使用TensorFlow。共享库libnvinferlibnvinfer_plugin是可选的,只有当你使用的是NVIDIA的TensorRT能力要求。

TensorFlow的安装说明列出了GPU的依赖关系:

以下NVIDIA®软件必须安装在系统上:

  • NVIDIA®GPU驱动程序-CUDA 10.1需要418.x或更高。
  • 工具包CUDA®支持-TensorFlow CUDA 10.1(TensorFlow> = 2.1.0)
  • CUPTI附带CUDA工具包。
  • cuDNN SDK(> = 7.6)
  • (可选)TensorRT 6.0改善延迟和吞吐量的推理在某些机型上。

你可以用下面的命令(取自在Ubuntu 18.04安装这些TensorFlow文档):

# Add NVIDIA package repositories
wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-repo-ubuntu1804_10.1.243-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu1804_10.1.243-1_amd64.deb
sudo apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub
sudo apt-get update
wget http://developer.download.nvidia.com/compute/machine-learning/repos/ubuntu1804/x86_64/nvidia-machine-learning-repo-ubuntu1804_1.0.0-1_amd64.deb
sudo apt install ./nvidia-machine-learning-repo-ubuntu1804_1.0.0-1_amd64.deb
sudo apt-get update

# Install NVIDIA driver
sudo apt-get install --no-install-recommends nvidia-driver-430
# Reboot. Check that GPUs are visible using the command: nvidia-smi

# Install development and runtime libraries (~4GB)
sudo apt-get install --no-install-recommends \
    cuda-10-1 \
    libcudnn7=7.6.4.38-1+cuda10.1  \
    libcudnn7-dev=7.6.4.38-1+cuda10.1


# Install TensorRT. Requires that libcudnn7 is installed above.
sudo apt-get install -y --no-install-recommends libnvinfer6=6.0.1-1+cuda10.1 \
    libnvinfer-dev=6.0.1-1+cuda10.1 \
    libnvinfer-plugin6=6.0.1-1+cuda10.1

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

来自分类Dev

PHP启动:无法加载动态库`curl.so` Ubuntu

来自分类Dev

无法加载动态库'oci8.so'(PHP 7.2)

来自分类Dev

PHP启动:无法加载动态库PGSQL

来自分类Dev

无法编译和链接动态库

来自分类Dev

PHP无法加载动态库“ libMagickWand”

来自分类Dev

无法加载动态库“ php_libsodium”

来自分类Dev

C ++:动态.so库中的类

来自分类Python

ImportError:libSM.so.6:无法打开共享库文件:没有这样的文件或目录

来自分类Linux

Android SDK-Aapt错误:libstdc ++。so.6无法打开共享库文件

来自分类Linux

红色语言控制台错误:libreadline.so.6:无法打开共享库文件

来自分类Java

无法装载CSV数据Elasticsearch,翻译的问题

来自分类Dev

无法在Docker CLI中装载卷

来自分类Dev

PHP启动无法加载动态库php_mongo.dll

来自分类Dev

PHP启动:无法加载动态库php_pdo_firebird

来自分类Dev

使用Laravel Intervention库无法缓存动态图像

来自分类Dev

PHP警告:PHP启动:无法在Ubuntu上加载动态库

来自分类Dev

CentOS 6.5-Plesk Onyx 17.0.17-PHP启动:无法加载动态库'/usr/lib64/php/modules/apc.so'

来自分类Dev

pybind创建的* .so文件与常规linux动态库之间的区别

来自分类Java

在Docker中装载卷时无法访问jarfile错误

来自分类Dev

Angular 6-无法在画布上动态添加文本

来自分类Dev

无法从ext数据库中的mysql数据库动态显示blob图像

来自分类Dev

如果pyinstaller无法找到动态库或自定义库,该怎么办?

来自分类Linux

从结构上讲,共享库(SO)和动态链接库(DLL)有什么区别?

来自分类Linux

无法加载JNA本机支持库Elasticsearch 6.x

来自分类Linux

wkhtmltopdf-libfontconfig.so.1:无法打开共享库文件

来自分类Dev

gcc无法找到共享库libisl.so

来自分类Dev

ImportError:libcublas.so.9.0:无法打开共享库文件

来自分类Linux

libaio.so.1:无法打开共享库文件

来自分类Dev

sqlcmd无法找到存在的库(libmsodbcsql-17.0.so.1.1)

TOP 榜单

热门标签

归档