如何同时使用角度1.3.4和角度2

莫希特(Mohit)Bumb

我已经有一个基于angular 1.3.4构建的应用程序,我想将其更改为angular 2,但要在模块方面进行更改。

可以说我的页面上有5个模块,我想将一个模块迁移到angular 2,而其他模块应该像以前的1.3一样工作,所以我可以慢慢地转换,但是直到它不停止为止。

我同时包含angular 2和angular 1.3.4库,并且说在控制台中未定义angular

莫伦代克

请阅读此博客:http : //angularjs.blogspot.nl/2015/08/angular-1-and-angular-2-coexistence.html

它说明了如何一起运行它以及如何最终升级到Angular 2。

该链接的重要之处在于:

为此,在Angular 1和Angular 2之间需要进行四件事互操作。

  • 依赖注入
  • 组件嵌套包含
  • 变更检测

为了使所有这些成为可能,我们正在构建一个名为ng-upgrade的库。您将在现有的Angular 1应用程序中包含ng-upgrade和Angular 2,并且可以随意混合和匹配。

因此,您需要ng-upgrade。在此处查看有关此信息的更多信息:https : //angular.io/docs/ts/latest/guide/upgrade.html

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

TOP 榜单

热门标签

归档