找不到'UserAgent.h'文件

曼普雷特·辛格·潘德

我正在使用Firebase开发Flutter应用程序时,使用firebaseAuth插件应用程序时出现以下错误

Launching lib/main.dart on iPhone 11 Pro Max in debug mode...
Running pod install...
Running Xcode build...
Xcode build done.                                           131.2s
Failed to build iOS app
Error output from Xcode build:
↳
2020-02-28 16:05:06.832 XCBBuildService[68423:382033] Failed to remove: 
/Users/apple/Library/Developer/Xcode/DerivedData/Runner- hfqwisipukhnqobtbsvjhfltdbgs/Build/Intermediates.noindex/XCBuildData/1be627f6c729f1a388e5fec96804d392-manifest.xcbuild: unlink(/Users/apple/Library/Developer/Xcode/DerivedData/Runner-hfqwisipukhnqobtbsvjhfltdbgs/Build/Intermediates.noindex/XCBuildData/1be627f6c729f1a388e5fec96804d392-manifest.xcbuild): No such file or directory (2)
2020-02-28 16:05:07.269 XCBBuildService[68423:382033] Failed to remove: /Users/apple/Library/Developer/Xcode/DerivedData/Runner-hfqwisipukhnqobtbsvjhfltdbgs/Build/Intermediates.noindex/XCBuildData/1be627f6c729f1a388e5fec96804d392-desc.xcbuild: unlink(/Users/apple/Library/Developer/Xcode/DerivedData/Runner-hfqwisipukhnqobtbsvjhfltdbgs/Build/Intermediates.noindex/XCBuildData/1be627f6c729f1a388e5fec96804d392-desc.xcbuild): No such file or directory (2)
* BUILD FAILED *


Xcode's output:
↳
/Users/apple/Library/Android/flutter/.pub-cache/hosted/pub.dartlang.org/firebase_auth-0.15.5+2/darwin/Classes/FLTFirebaseAuthPlugin.m:7:9: fatal error: 'UserAgent.h' file not found
#import "UserAgent.h"
        ^~~~~~~~~~~~~
1 error generated.
note: Using new build system
note: Planning build
note: Constructing build description

Could not build the application for the simulator.
Error launching application on iPhone 11 Pro Max.

我正在使用这些库-

firebase_auth: ^0.15.5+2
firebase_storage: ^3.1.1
cloud_firestore: ^0.13.4

任何人都知道如何解决此错误?,我已经做了以下事情

flutter clean
deleted podfile.lock
deleted pods folder
pod deintegrate
pod repo update
pod install

但不要帮我解决这个错误

汤姆布鲁

我们正在努力解决相同的错误。看来这是firebase_auth依赖项错误(firebase_core v0.4.4 + 2)。

首先,运行flutter clean,然后将对pubspec.yaml的依赖项更改为

dependencies: 
  firebase_auth: 0.15.4
dependency_overrides:
  firebase_core: 0.4.4

希望能帮助到你!

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章