WordPress如何告诉我的CSS版本

塞多克

正在开发wordpress主题时,wordpress会自动将我加起来,style.css但是会分配一个我现在不知道的版本号,下面是版本值,下面的链接是一个wordpress系统添加到我的每页首页中,而CSS版本是是4.3.1。

<link rel='stylesheet' id='twentytwelve-style-css'  href='http://localhost/xyzwebsite/wp-content/themes/twentytwelve-child/style.css?ver=4.3.1' type='text/css' media='all' />

我想成为这样

<link rel='stylesheet' id='twentytwelve-style-css'  href='http://localhost/xyzwebsite/wp-content/themes/twentytwelve-child/style.css?ver=3.8.11' type='text/css' media='all' />
dingo_d

如果我没记错的话,您需要 style.css

/*
Theme Name: ThemeName
Version: 1.0.0
Author: yourname
Author URI: http://yourwebsite.com
Description: your description
Theme URI: your theme URL
License: GNU General Public License v2 or later
License URI: http://www.gnu.org/licenses/gpl-2.0.html
Tags: random tags go here
*/

就在最上面 另外,在您的functions.php文件中,您还需要

<?php
define('THEME_NAME', 'ThemeName');
define('THEME_VERSION', '1.0.0');

然后使用以下命令将其排队在functions.php中

wp_enqueue_style('main_css', get_stylesheet_uri(), array(), THEME_VERSION);

如果要在数组中使用,可以使其依赖于其他样式表,然后使用主题版本。

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

一旦告诉我的共享主机,如何告诉Deployer使用不同的PHP版本?

谁能告诉我如何实现?

我可以告诉我程序是哪个ghc版本的吗?

谁能告诉我如何将sass自动编译为CSS?

请告诉我如何在 CSS 中使用变量作为属性值

你能告诉我如何使用InvokeScriptTransaction

告诉我如何填充二维数组

ffmpeg依赖错误告诉我什么,如何解决?

如何告诉我的IDE以特定方式编译CMake项目?

如何告诉我的测试等待goroutine中的回调?

告诉我如何安装React JS文档

如何告诉我的应用忽略特定的触摸?

谁能告诉我这种效果是如何实现的?

请告诉我这个 UI 名称是如何命名的

告诉我如何以角度显示 json 对象值?

请告诉我如何编写nuxt插件'printd'

如何让pyautogui告诉我locateOnScreen函数的坐标

如何告诉我的PHP脚本运行Javascript函数?

告诉我`String n = null;`是如何工作的?

Pascal,请告诉我这个循环是如何工作的

请告诉我如何制作跟随角色的UI

PHP 请告诉我如何访问对象键

你能告诉我这个 Solidity 是如何工作的吗?

我使用jdk8,但Spring告诉我我需要jdk5或更高版本

是否有任何 Forge API 能够告诉我创建该文件的软件版本

Flash插件为最新版本,但Firefox不断告诉我我使用的是旧版本

我如何告诉我的内部IP发送到我的外部IP?

我想学习编程 我是新来的 谁能告诉我应该如何开始?

有没有工具可以告诉我是否有未使用的CSS类?