我使用jdk8,但Spring告诉我我需要jdk5或更高版本

Wangbo

在.java中

System.out.println(System.getProperty("java.version"));

我有

1.8.0_45

但是当我把它包装成罐子包装并在另一个项目中使用时,它告诉我

Offending resource: class path resource [applicationContext.xml];
nested exception is
org.springframework.beans.factory.BeanDefinitionStoreException:
Unexpected exception parsing XML document from class path resource
[applicationContextYQ.xml]; nested exception is
java.lang.IllegalStateException: Context namespace element
'component-scan' and its parser class
[org.springframework.context.annotation.ComponentScanBeanDefinitionParser]
are only available on JDK 1.5 and higher

为什么?

在cmd中

C:\ Users \ idea> java -version

Java版本“ 1.8.0_45”

Java(TM)SE运行时环境(内部版本1.8.0_45-b15)

Java HotSpot(TM)64位服务器VM(内部版本25.45-b02,混合模式)

阿维胡(Avihoo)妈妈

尝试将以下代码添加到项目的pom.xml中:

<plugin>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.3</version>
 <configuration>
    <source>1.8</source>
    <target>1.8</target>
    <compilerArgument />
    </configuration>
</plugin>

并且还可以包含对JAR的所有依赖关系:

<plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-assembly-plugin</artifactId>
            <configuration>
                <descriptors>
                    <descriptor>src/assembly/assembly.xml</descriptor>
                </descriptors>
            </configuration>
            <executions>
                <execution>
                    <id>package-all</id>
                    <phase>package</phase>
                    <goals>
                        <goal>single</goal>
                    </goals>
                </execution>
            </executions>
</plugin>

并在src / assembly下有assembly.xml(或根据需要更改路径):

<assembly xmlns="http://maven.apache.org/plugins/maven-assembly-plugin/assembly/1.1.3"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/plugins/maven-assembly-plugin/assembly/1.1.3 http://maven.apache.org/xsd/assembly-1.1.3.xsd">
    <id>jar-with-dependencies</id>
    <formats>
        <format>jar</format>
    </formats>
    <includeBaseDirectory>false</includeBaseDirectory>
    <dependencySets>
        <dependencySet>
            <outputDirectory>/</outputDirectory>
            <useProjectArtifact>true</useProjectArtifact>
            <unpack>true</unpack>
            <scope>runtime</scope>
        </dependencySet>
    </dependencySets>
</assembly>

本文收集自互联网,转载请注明来源。

如有侵权,请联系 [email protected] 删除。

编辑于
0

我来说两句

0 条评论
登录 后参与评论

相关文章

如何知道我的机器上的JDK版本?

我需要的Java JDK使用Android的工作室?

java -version是否告诉我有关JRE或JDK的信息?

我需要使用JDK 13.0.2编译哪个版本的JRE?

为什么我的Eclipse Luna 4.4在使用Oracle JDK8 64bit的Debian Wheezy 7.4上崩溃?

我们应该如何管理jdk8流中的空值

使用JDK5的btrace

我需要JDK还是仅JRE?

在ubuntu上配置eclipse以使用我的jdk版本

我可以使用具有不同JDK版本的多个spring-boot容器吗?

谁能告诉我为什么8> 7 <6 = true?

为什么MySQL Workbench告诉我我需要分号?

使用JDK8 Lambda的FizzBuzz

我可以告诉我程序是哪个ghc版本的吗?

一旦告诉我的共享主机,如何告诉Deployer使用不同的PHP版本?

我可以得到哪个版本的openjdk8来构建更新131,与oracle的最新版本相同?jdk8 / jdk8u?

为什么Powershell告诉我我需要。\

Flash插件为最新版本,但Firefox不断告诉我我使用的是旧版本

Ubuntu告诉我我需要更多空间

paintComponent告诉我我使用的是对象而不是图形

java -version告诉我8但jdk是1.7-OSX 10.9.x

我需要安装JDK的帮助

WordPress如何告诉我的CSS版本

React告诉我我正在开发中使用Minified ...

类方法告诉我,我又使用了1个pos。争论比需要的,但我没有

如何让 maven 识别我的 jdk 版本?

我想在 JDK 8 中使用 `jshell`

为什么我得到的 pom 可以由 jdk8、10、11、12 构建,但不能由 jdk9 构建?

错误:JDK 1.8 或更高版本的需求检查失败。我使用的是 java 16.0